London IPSec VPN's
Incident Report for Pelion Connectivity Management
Resolved
This incident has been resolved.
Posted Jun 12, 2021 - 06:42 BST
Investigating
We are investigating issues with IPSec VPN hosted from our London datacenter and will provide an update shortly.
Posted Jun 12, 2021 - 06:07 BST
This incident affected: VPN Technology (London IPSecs).