Pelion // Tele2 Connectivity

Incident Report for Pelion Connectivity Status

Resolved

After a period of monitoring we are satisfied that the issue has been resolved.
Posted Jul 10, 2026 - 18:55 BST

Monitoring

Status:
Incident Update

Pelion Support teams have identified from our monitoring and discussions with Tele2 that we observed a spike in Radius failures since approx. 16: 20 BST

The impact on customer services is that new connection attempts may have been temporarily impacted and several retries may have been required.

As of 16:40 BST Pelion Support teams have performed a managed failover on to an alternative host to mitigate the issue and normal connection behavior has since been observed, we will continue to monitor for a period of stability.

We apologise for any inconvenience.
Posted Jul 10, 2026 - 16:51 BST
This incident affected: Mobile Operators (Tele2).