Pelion // Global Cloudflare Issues Reported

Incident Report for Pelion Connectivity Status

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 19:02 GMT

Monitoring

Cloudflare are seeing errors and latency return to normal levels and Pelion have observed higher levels of stability across our platforms.

We will continue to monitor this incident.
Posted Nov 18, 2025 - 17:20 GMT

Update

We are continuing to work on a fix for this issue.
Posted Nov 18, 2025 - 14:17 GMT

Identified

Cloudflare have advised they are seeing services recover, but customers may continue to observe higher-than-normal error rates.

Pelion will continue to monitor the recovery of this service.
Posted Nov 18, 2025 - 12:33 GMT

Investigating

Pelion are observing an impact to services protected and routed by Cloudflare.

Cloudflare provide security and network infrastructure for websites and services across the internet, the current outage is still being investigated by Cloudflare and we will provide updates as they become available

This will be currently impacting the Pelion platform.


Customers can follow the cloudflare status page for further information:

https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 12:08 GMT
This incident affected: Mobile Operators (Pelion Global Roaming, EE, O2, Tele2, Three IRE, Three UK, Vodafone, Vodafone Global, Telus, Vodafone NB-IoT (LPWAN)) and Pelion (Analytics, API, Help.pelion.com, Pelion Platform, Pelion US Platform).