Tele2 have informed us that this incident has now been fully resolved.
Posted May 14, 2025 - 19:06 BST
Investigating
Status: Investigating Incident
Service Impacted: Tele2 subscribers minor degradation in 4G services
Priority: Medium
Pelion Environment Area(s) Affected: UK / US
Summary:
Pelion Support teams are currently investigating issues with Tele2 4G degradation which may have an impact on your service. Tele2 have notified Pelion that subscribers are experiencing a minor degradation in 4G/LTE services. Some users may need multiple attempts to authenticate into 4G roaming networks. However, once successfully registered, 4G sessions are established without issues. Additionally, approximately 10% of VoLTE-capable devices may experience registration failures, potentially affecting voice over LTE services.
Other services - including voice, SMS, and 2G/3G data - remain unaffected.
Update:
Support teams have assessed and believe the impact to be low at this time.
We will provide an update shortly and we apologise for any inconvenience.