Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 27, 2025 - 09:00 BST
Scheduled
We'll be carrying out planned works as we migrate our secondary data centre from Miami to our new facility in Las Vegas. This upgrade is part of our ongoing efforts to improve the resilience and performance of our services.
Location: USA
Start Date and time: 27/05/2025 09:00 BST (03:00 CT)
End Date and time: 06/06/2025 17:00 BST (11:00 CT)
What to Expect: During the maintenance window, services currently hosted in Miami may experience one or more brief reconnection events. To minimise disruption, traffic will be automatically rerouted via our Austin data centre while the work is underway.
The potential impact times during each day are between 09:00 - 13:00 BST (03:00 - 07:00 CT)
Services affected: Whilst Pelion will take all precautionary efforts to move any traffic to Austin before the changes, there is still some services that would be considered as at risk.
Telus subscriber traffic is at risk of a reconnection event during the impact times on each day. Customer VPNs that have secondary tunnels that terminate in Miami may see a reconnection event during the impact times on each day.
Customer action required: No action is needed on your part. Everything will be handled by our team. However, if you notice any extended issues during this time, please reach out to our technical support team — we're here to help.
Posted May 05, 2025 - 15:24 BST
This scheduled maintenance affects: Infrastructure (Miami Datacentre).