Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 13, 2024 - 17:00 GMT
Update
The maintenance window has been updated to 4 hours. 17:00 - 21:00 UTC.
Posted Nov 08, 2024 - 13:41 GMT
Update
This work has been rescheduled to the 13th November.
Posted Nov 05, 2024 - 14:44 GMT
Scheduled
We will be carrying out essential maintenance on 06/11/2024 between 17:00 and 19:00 UTC.
During this time we will be carrying out essential maintenance on our integrations with JT and EE..
Start Date and time: 13/11/2024 17:00 UTC
End Date and time: 13/11/2024 19:00 UTC
Services affected: During this maintenance period there is potential for a delay in new session authentication for JT/Pelion Global Roaming and EE subscribers and those subscribers should be considered at-risk during the maintenance period.
Customer action required: No customer action is required.
Posted Nov 01, 2024 - 14:18 GMT
This scheduled maintenance affected: Mobile Operators (Pelion Global Roaming).