Pelion // Three UK Degradation

Incident Report for Pelion Connectivity Status

Resolved

The Pelion SRE team has found and mitigated the issue. Service will resume as usual.
Posted Jan 06, 2026 - 18:20 GMT

Investigating

Pelion Teams are currently investigating degradation connecting with Three UK in one of our sites. Connectivity is still possible from our backup site, although customers may experience reconnections and momentary loss of service.
Posted Jan 06, 2026 - 17:51 GMT
This incident affected: Infrastructure (London Datacentre) and Mobile Operators (Three UK).