Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 17, 2026 - 11:00 BST
Scheduled
Pelion are carrying out essential maintenance on Thursday 17 September 2026 between 11:00 and 14:00 BST.
This continues yesterday's work at the Manchester data centre, which was rescheduled because essential new equipment arrived late on site. Pelion engineers will install that equipment during this window.
Start date and time: 17/09/2026, 11:00 BST
End date and time: 17/09/2026, 14:00 BST
Services affected The Pelion Platform may be unavailable for a short period while we migrate it to the London data centre. Customers using EE and Tele2 SIMs may see their data sessions disconnect and reconnect. VPNs terminating in Manchester may disconnect and reconnect.
Customer action required
None.
Posted Sep 17, 2026 - 10:23 BST
This scheduled maintenance affected: Mobile Operators (EE, Tele2), Infrastructure (Manchester Datacentre), VPN Technology (Manchester IPSecs), and Pelion (Pelion Platform).