Pelion // Issues Roaming on EE

Incident Report for Pelion Connectivity Status

Resolved

This incident has been resolved.
Posted Jun 18, 2026 - 18:34 BST

Update

Status: Monitoring

Update:
EE believe to have identified a configuration error and resolved the roaming incident and we are now seeing traffic levels return to normal across Tele2, Three Ireland and Velos.

Priority:
High

Pelion Environment Area(s) Affected:
UK and EU

Summary:
Please monitor your affected devices and report any SIMs still showing issues. Resolution applies to data, SMS and voice.
Posted Jun 18, 2026 - 16:46 BST

Monitoring

Status: Investigating and Monitoring

Service Impacted:
Roaming services including data, SMS and voice are currently unavailable on the EE network. This is affecting all roaming operators including Tele2, Velos and Three Ireland

Priority:
High

Pelion Environment Area(s) Affected:
UK and EU

Summary:
The BT/EE support teams are currently investigating this issue as a P1 and we expect further update at 16.30. In the meantime, please contact support@pelion.com if you are experiencing issues related to this outage on your roaming SIMs.
Posted Jun 18, 2026 - 14:25 BST
This incident affected: Mobile Operators (Pelion Global Roaming, Tele2, Three IRE).