Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 21, 2026 - 11:00 BST
Scheduled
We will be carrying out essential maintenance on 21/05/2026 between 11:00 and 12:00 BST.
During this time we will be performing a failover of the primary radius feed for Vodafone Global and NB-IoT SIMs from our London to Manchester datacentres. Little to no impact is expected, if a device is trying to authenticate at the time of the failover it will require a retry. No impact to data transfer is expected.
Start Date and time: 21/05/2026 11:00 BST
End Date and time: 21/05/2026 12:00 BST
Services affected: Vodafone Global and NB-IoT. Little to no impact is expected, if a device is trying to authenticate at the time of the failover it will require a retry. No impact to data transfer is expected.
Customer action required: No customer action is required.
Posted May 20, 2026 - 17:07 BST
This scheduled maintenance affected: Mobile Operators (Vodafone Global, Vodafone NB-IoT (LPWAN)).