Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 09, 2025 - 08:00 BST
Scheduled
We will be carrying out essential maintenance on 09/07/2025 between 08:00 and 12:00 BST.
During this time we will be bringing up a new cross-site link between our Austin and Las Vegas datacentres. Telus subscribers may disconnect and reconnect briefly within the maintenance window.
Location: US
Start Date and time: 09/07/2025 08:00 BST / 02:00 Central
End Date and time: 09/07/2025 12:00 BST / 06:00 Central
Services affected: Austin and Las Vegas datacentres. Telus subscribers may disconnect and reconnect briefly within the maintenance window.
Customer action required: No customer action is required.
Posted Jul 04, 2025 - 15:49 BST
This scheduled maintenance affected: Infrastructure (Austin Datacentre, Las Vegas Datacentre) and Mobile Operators (Telus).