We have received reports from our mobile network partners who have informed us that regional electricity companies have restored power in the affected areas and the majority of impacted sites have returned to full operating service.
Posted Mar 21, 2025 - 14:53 GMT
Investigating
Pelion have been notified by BT that they have experienced a loss of power to cell sites in and around some London postcodes.
This is following the power issues and fire in which has impacted the areas around the London post codes of TW3, TW4, TW5, TW6, UB1, UB2, UB4, UB7 and UB8.
Other cells sites from other network providers may also be impacted in and around these areas.
BT are working to restore power to these areas.
Customers should be aware of the power outages in these areas which may be impacting service.
Pelion are continuing to monitor the situation.
Posted Mar 21, 2025 - 10:40 GMT
This incident affected: Mobile Operators (Pelion Global Roaming, EE, O2, Tele2, Three IRE, Three UK, Vodafone, Vodafone Global, Vodafone NB-IoT (LPWAN)).