Pelion // Pelion Email Support Ticketing
Incident Report for Pelion Connectivity Status
Resolved
Status: Incident Update

Service Impacted: Pelion Email Support Ticketing

Priority: Medium

Pelion Environment Area(s) Affected: UK & US

Incident Start Time: 21/06/2022 09:34UTC

Incident Stop Time: 22/06/2022 12:00

Update: We would like to inform you that this issue has now been resolved and tickets are being received as normal now. If you experience any issues or tickets are not responded to in a timely manner, please call our support number for assistance. Thank you and apologies for any inconvenience this has caused.

Incident Summary:
Pelion Support teams have been advised by our ticketing supplier that Support tickets may not be delivered to our support teams when emailed to pcm-support@pelion.com

Update:
Pelion Support teams believe they have identified the problem and are working on a solution in conjunction with the supplier to fully resolve this issue. The next update will be within 24 hours or earlier if the resolution is implemented.

Customers are advised to contact the Pelion Support team via the Support Portal: support.pelion.com
or call us on the below contact phone numbers:

o United Kingdom
▪ Local: + 44 (0)844 800 8520
▪ Local: +44 (0)808 196 5001

▪ International: +44 141 483 7545

o United States of America
▪ Local: +1 855 755 0065
▪ International: +1 650 300 0065

We apologise for any inconvenience caused.
Posted Jun 22, 2022 - 12:06 BST
Identified
Status: Incident Update

Service Impacted: Pelion Email Support Ticketing

Priority: Medium

Pelion Environment Area(s) Affected: UK & US

Incident Start Time: 21/06/2022 09:34UTC

Next Update: Within 24 hours

We would like to inform you that we are currently investigating issues with the Pelion Email Support Ticketing system which may have an impact on customers being able to raise tickets through our support email address: pcm-support@pelion.com

Incident Summary:
Pelion Support teams have been advised by our ticketing supplier that Support tickets may not be delivered to our support teams when emailed to pcm-support@pelion.com

Update:
Pelion Support teams believe they have identified the problem and are working on a solution in conjunction with the supplier to fully resolve this issue. The next update will be within 24 hours or earlier if the resolution is implemented.

Customers are advised to contact the Pelion Support team via the Support Portal: support.pelion.com
or call us on the below contact phone numbers:

o United Kingdom
▪ Local: + 44 (0)844 800 8520
▪ Local: +44 (0)808 196 5001

▪ International: +44 141 483 7545

o United States of America
▪ Local: +1 855 755 0065
▪ International: +1 650 300 0065

We apologise for any inconvenience caused.
Posted Jun 21, 2022 - 15:42 BST
Investigating
Status: Investigating Incident

Service Impacted: Pelion Email Support Ticketing

Priority: Medium

Pelion Environment Area(s) Affected: UK & US

Incident Start Time: 21/06/2022 09:34UTC

We would like to inform you that we are currently investigating issues with the Pelion Email Support Ticketing system which may have an impact on customers being able to raise tickets through our support email address: pcm-support@pelion.com

Incident Summary:
Pelion Support teams have been advised by our supplier that Support tickets may not be delivered to our support teams when emailed to pcm-support@pelion.com

Customers are advised to contact the Pelion Support team via the Support Portal: support.pelion.com
or call us on the below contact phone numbers:

o United Kingdom
▪ Local: + 44 (0)844 800 8520
▪ Local: +44 (0)808 196 5001

▪ International: +44 141 483 7545

o United States of America
▪ Local: +1 855 755 0065
▪ International: +1 650 300 0065


We are currently invoking internal teams and working with our supplier to assist in resolving the issue.


We apologise for any inconvenience.
Posted Jun 21, 2022 - 10:50 BST
This incident affected: Services (Support Ticketing).