Storm Floris - UK

Incident Report for Pelion Connectivity Status

Resolved

This incident has been resolved.
Posted Aug 05, 2025 - 10:39 BST

Monitoring

Pelion are monitoring the effects of Storm Floris within the duration of the amber weather warning.

No impact to service operations is currently observed.

The Pelion teams are still available to be contacted via the normal channels.
Posted Aug 04, 2025 - 09:34 BST
This incident affected: Mobile Operators (Pelion Global Roaming, EE, O2, Tele2, Three IRE, Three UK, Vodafone, Vodafone Global, Vodafone NB-IoT (LPWAN)), Pelion Private APN, Infrastructure (London Datacentre, Manchester Datacentre, RADIUS), Services (Customer Phone line, Internal Support Systems, Statuspage, Support Ticketing), Pelion (Analytics, API, Help.pelion.com, Pelion Platform), and VPN Technology (DINA, London IPSecs, Manchester IPSecs, OpenVPN).