Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 11, 2025 - 16:00 GMT
Scheduled
We will be carrying out essential maintenance on 11/03/2025 between 16:00 and 23:00 UTC.
During this time we will be performing routine maintenance in our Manchester datacentre. No impact is expected, however Manchester datacentre services may be at risk of some disruption within the maintenance window.
Location: Manchester UK
Start Date and time: 11/03/2025 16:00 UTC
End Date and time: 11/03/2025 23:00 UTC
Services affected: Manchester datacentre. No impact is expected, however Manchester datacentre services may be at risk of some disruption within the maintenance window.
Customer action required: No customer action is required.
Posted Mar 07, 2025 - 17:20 GMT
This scheduled maintenance affected: Mobile Operators (Pelion Global Roaming, EE, Tele2, Three UK), VPN Technology (Manchester IPSecs, OpenVPN), and Infrastructure (Manchester Datacentre).