Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 03, 2025 - 23:00 GMT
Scheduled
Tele2 will be carrying out essential maintenance on 03/11/2025 between 23:00 and 02:00 UTC.
During this time Tele2 are carrying out VPNC upgrades to maintain service quality and reliability.
Start Date and time: 03/11/2025 23:00 UTC
End Date and time: 04/11/2025 02:00 UTC
Services affected: There is no expected impact to live customer sessions during this maintenance as Pelion has resilient links to Tele2, however there is the possibility for new data session attaches to be momentarily delayed during the maintenance period when Tele2 failover between VPNCs, as this could briefly interrupt our RADIUS feed to Tele2.
Customer action required: No customer action is required.
Posted Oct 31, 2025 - 18:34 GMT
This scheduled maintenance affected: Mobile Operators (Tele2).