Pelion // Microsoft Services
Incident Report for Pelion Connectivity Status
Resolved
The Microsoft issues reported today did not have any impact to Pelion's networks or service.
We did not see any disruption to customer traffic or customer services.

We would encourage any impacted customers to keep updated with Microsoft.

Please reach out to our support team if Pelion can help in any way; From identifying why your service is failing, assisting in mitigation plans or aid in your business continuity plans you can count on us to be there for you.
Posted Jul 19, 2024 - 16:55 BST
Investigating
Pelion are aware of issues affecting Microsoft applications and services, these outages are not currently impacting Pelion connectivity worldwide but we will continue to monitor.

This incident may be affecting upstream and downstream services out-with Pelion networks, but we are not presently seeing any major disruption to customer traffic or services.

As this is an ongoing issue we may continue see subsequent disruption to services which we rely on, we will continue to notify you as this situation evolves.
Posted Jul 19, 2024 - 09:43 BST
This incident affected: Mobile Operators (Pelion Global Roaming, EE, O2, Tele2, Three IRE, Three UK, Vodafone, Vodafone Global, Telus, Vodafone NB-IoT (LPWAN)) and Pelion (Pelion Platform).