Pelion // JT/Pelion Global Roaming // Degraded Performance

Incident Report for Pelion Connectivity Status

Resolved

Status:
Resolved

We would like to inform you that this incident has been resolved by the network supplier.

We apologise for any inconvenience.
Posted Jul 16, 2026 - 07:21 BST

Update

Status:
Monitoring

The network operator's packet core team has found an issue with a node on their network and is working to resolve this.

Pelion continues to observe that the issue appears to be mitigated for our radius and no impact is observed.

We apologise for any inconvenience and we will provide further updates as we receive them from the supplier.
Posted Jul 16, 2026 - 05:45 BST

Update

We are continuing to monitor for any further issues.
Posted Jul 16, 2026 - 04:42 BST

Monitoring

Status: Monitoring

Service Impacted:
JT/Pelion Global Roaming

Priority:
Medium

Pelion Environment Area(s) Affected:
UK&EU

Summary:

Pelion Support teams are currently investigating issues with the Pelion Global roaming/JT SIM supplier which may have caused an impact on your service.
We identified from monitoring an increase in radius messages and events which caused alerting on Pelion's side. This may have caused devices to disconnect and reconnect or to authenticate more frequently than normal.
Pelion engineering teams increased the radius capacity and the issue seems to have stabilised.

We have engaged the network supplier to investigate further as we believe an underlying network event could be the root cause.

Pelion will continue to monitor for any further impact but we believe the immediate issue is mitigated.


We will provide an update shortly and we apologise for any inconvenience.
Posted Jul 16, 2026 - 04:41 BST
This incident affected: Mobile Operators (Pelion Global Roaming).