Pelion // Three Ireland - 4G Attach Degradation

Incident Report for Pelion Connectivity Status

Resolved

This incident has been resolved.
Posted Jul 14, 2025 - 17:52 BST

Investigating

Status: Investigating Incident

Service Impacted:
Three Ireland - 4G Attach Degradation

Priority:
High

Pelion Environment Area(s) Affected:
UK & EU

Summary:

Three Ireland have reported to Pelion Support teams that they are currently experiencing a 4G Attach degradation incident across all roaming carriers. This may be causing devices to struggle to attach to a 4G network and create a new data session.
Devices which currently in a data session should not be impacted.

Update:
We will provide further updates as we receive them from Three Ireland.


We will provide an update shortly and we apologise for any inconvenience.
Posted Jul 14, 2025 - 15:46 BST
This incident affected: Mobile Operators (Three IRE).