Pelion // EE/BT - Intermittent Connectivity Issues

Incident Report for Pelion Connectivity Status

Resolved

Status:
Resolved

We would like to inform you that following a period of monitoring, this incident is resolved.

We apologise for any inconvenience.
Posted Nov 28, 2025 - 15:27 GMT

Monitoring

Status:
Monitoring

The connectivity issue looks to have stabilised.
We are working with EE/BT to continue monitoring and to understand the root cause of the issue.

Customers may have to reboot/power cycle their devices in the first instance.

We apologise for any inconvenience.
Posted Nov 28, 2025 - 11:40 GMT

Investigating

Status: Investigating Incident

Service Impacted:
EE/BT

Priority:
High

Pelion Environment Area(s) Affected:
UK

Summary:

Pelion Support teams are currently investigating issues with EE/BT which may have an impact on your service.
We have identified from monitoring that Pelion are experiencing intermittent connectivity back into EE/BT's core network.

Pelion subscribers with EE/BT SIMs may see intermittent connectivity issues.

Update:
Pelion support and engineering are investigating and we have also engaged BT to investigate.


We will provide an update shortly and we apologise for any inconvenience.
Posted Nov 28, 2025 - 10:57 GMT
This incident affected: Mobile Operators (EE).