Three UK 4G Degradation
Incident Report for Pelion Connectivity Status
Resolved
This incident has been resolved.
Posted Jun 22, 2020 - 19:37 BST
Update
Three have now resolved this issue.
Posted Jun 22, 2020 - 19:34 BST
Investigating
Three UK have identified and notified us of a potential issue on a small percentage of SIM's which may be experiencing degraded data performance when on 4G. There is no impact to 3G. They have advised us they are investigating the issue, further updates to follow.
Posted Jun 22, 2020 - 16:25 BST
This incident affected: Mobile Operators (Three UK).