Pelion Global Roaming SIMs
Incident Report for Pelion Connectivity Management
Resolved
Resolving this incident. Pelion's Global roaming provider has indicated that their network connectivity has been normalized and devices should now be able to establish a connection. Messaging services have now been restored as well. Please reach out to pcm-support@pelion.com if you continue to experience any issues.
Posted Oct 25, 2021 - 21:15 BST
Update
Pelion's Global roaming provider has informed that they are seeing early signs of recovery with 4G services. 2G & 3G services are still congested but are improving. Messaging services are intermittent in terms of successful message delivery - particularly for time critical messages. Provider's engineers are actively working on this until services are fully restored.
Posted Oct 25, 2021 - 19:55 BST
Update
Pelion's network roaming partner is continuing to investigate the issue.

Some devices may disconnect and reconnect, during this incident.

We will provide an update as soon as we get anything further from the the network provider.
Posted Oct 25, 2021 - 16:45 BST
Investigating
Pelion's Global roaming provider is currently investigating issues with their network.
As such the network provider has advised that any new update location requests may be taking longer and SIMs may be taking longer to attach to the network.

We will provide an update as soon as we get anything further from the the network provider.
Posted Oct 25, 2021 - 16:18 BST
This incident affected: Mobile Operators (Pelion Global Roaming).