Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 24, 2025 - 17:00 BST
Scheduled
We will be carrying out essential maintenance on 24/06/2025 between 17:00 and 19:30 BST.
During this time we will be improving performance and resiliency on Three by updating the configuration of the radius nodes. Subscribers will reconnect and experience some short disruptions to data traffic throughout the maintenance period as individual nodes are updated and tested. Devices should reconnect to an operational node and continue data traffic after reconnecting.
Start Date and time: 24/06/2025 17:00 BST
End Date and time: 24/06/2025 19:30 BST
Services affected: Three UK and Three Ireland. Subscribers will reconnect and experience some short disruptions to data traffic throughout the maintenance period as individual nodes are updated and tested. Devices should reconnect to an operational node and continue data traffic after reconnecting.
Customer action required: No customer action is required.
Posted Jun 20, 2025 - 15:15 BST
This scheduled maintenance affected: Mobile Operators (Three IRE, Three UK).