Pelion // Austin DC VPNC Issue

Incident Report for Pelion Connectivity Status

Resolved

This incident has been resolved.
Posted Mar 20, 2026 - 10:25 GMT

Monitoring

We identified the root cause and are now seeing recovery of services, will continue to monitor.
Posted Mar 19, 2026 - 14:04 GMT

Identified

Status:
Incident Update

Pelion Support teams have identified an issue with our VPNC service in Austin.

• Pelion Support teams/SRE are investigating.

We apologise for any inconvenience.
Posted Mar 19, 2026 - 13:29 GMT
This incident affected: Infrastructure (Austin Datacentre) and VPN Technology (Austin IPsec's).