O2 UK issues on 2G, 3G and 4G Data
Resolved
O2 have advised that this incident has been resolved.
Posted Jun 23, 2020 - 12:35 BST
Investigating
O2 are investigating issues with 2G, 3G and 4G data and will provide an update shortly.
Posted Jun 23, 2020 - 11:44 BST
This incident affected: Mobile Operators (O2).