Verification is currently underway for the maintenance items.
Posted Jul 30, 2026 - 14:22 BST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 30, 2026 - 13:00 BST
Scheduled
We will be carrying out essential maintenance on 30/07/2026 between 13:00 and 15:00 BST.
During this time we will be upgrading the capacity of our link between Pelion and BT/EE.
Start Date and time: 30/07/2026 13:00 BST
End Date and time: 30/07/2026 15:00 BST
Services affected: BT/EE subscribers may see a brief reconnection event as we move between hosts. The upgrade will be carried out on our backup host and impact should be minimal, however BT/EE subscribers should be considered at risk during the maintenance period.
Customer action required: No action Required.
Posted Jul 30, 2026 - 12:22 BST
This scheduled maintenance affected: Mobile Operators (EE).