Pelion // Tele2 Authentication Delay and Subscriber Reconnection

Incident Report for Pelion Connectivity Status

Resolved

This incident has been resolved.
Posted Jun 22, 2026 - 01:56 BST

Monitoring

Status: Monitoring

Summary:
Our escalation teams have applied mitigations and are monitoring improvements, and we have engaged our network partners to identify a root cause.
Posted Jun 22, 2026 - 01:37 BST

Update

We are continuing to investigate this issue.
Posted Jun 22, 2026 - 00:55 BST

Investigating

Status: Investigating

Service Impacted:
Tele2 subscribers will see delay in authenticating to the Pelion network. Subscribers may also see a reconnection or drop in data traffic.

Priority:
High

Pelion Environment Area(s) Affected:
UK and EU

Summary:
The Pelion escalation teams are currently investigating this issue.
Posted Jun 22, 2026 - 00:54 BST
This incident affected: Mobile Operators (Tele2).