Pelion // Pelion Platform EU

Incident Report for Pelion Connectivity Status

Resolved

This incident has been resolved.
Posted Apr 13, 2026 - 13:49 BST

Monitoring

Status: Monitoring Incident

Service Impacted:
Pelion Platform EU

Priority:
Low

Pelion Environment Area(s) Affected:
UK & EU

Summary:

Pelion Support teams identified an issue with the Pelion Platform EU data source where some informational fields were not populating. The incident has been rectified and data population is restoring. We are monitoring this.
Posted Apr 13, 2026 - 11:14 BST
This incident affected: Pelion (Pelion Platform).