Pelion SRE teams are observing service impact to be recovering as of approx. 01:20 BST - We will keep this maintenance window open and consider the services still as at-risk until the advertised maintenance period is complete.
Posted Apr 16, 2025 - 01:27 BST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 16, 2025 - 01:09 BST
Scheduled
Pelion has received notification from our data centre partner that they are carrying out planned works tonight between 00:01 - 06:00 BST
We unfortunately did not receive advanced noticed of this to our correct mailbox.
During this time our data centre partner are carrying our essential maintenance which has impacted some Pelion services.
Location: Manchester UK
Start Date and time: 16/04/2025 00:00 UTC
End Date and time: 16/04/2025 06:00 UTC
Services affected: Pelion EU platform and API VPNs hosted at our Manchester Data Centre Outbound internet facing connectivity
Our supplier has advised that the impact time should not exceed 150 minutes within the noted maintenance window and we are working to mitigate any impact.
Posted Apr 16, 2025 - 01:08 BST
This scheduled maintenance affected: Pelion (API, Pelion Platform), VPN Technology (Manchester IPSecs), and Infrastructure (Manchester Datacentre).