Our data centre partners have implemented a fix. All Pelion services should now be restored and available.
Posted Apr 22, 2025 - 16:25 BST
Identified
Our data centre provider in Austin has confirmed a hardware issue has occurred, Pelion have initiated internal protocols to move impacted services to our Miami data centre where possible.
This means that dual sited VPN services should be available again, however any single sited VPNs hosted in Austin will remain impacted.
Telus subscriber traffic is returning to normal levels.
Pelion platform services remain unavailable at this time.
Posted Apr 22, 2025 - 14:07 BST
Investigating
Status: Investigating Incident
Service Impacted: US platform and VPN connectivity
Priority: Medium
Pelion Environment Area(s) Affected: US
Summary:
Pelion Support teams are currently investigating issues with US platform, VPN and Cellular connectivity which may have an impact on your service. We have identified from our internal monitoring and alerting that customers may be experiencing intermittent issues with VPNs, Cellular Connectivity and access the Connectivity Management Platform. This issue is being investigated in conjunction with our upstream supplier where the issues have been identified.
Posted Apr 22, 2025 - 12:27 BST
This incident affected: Infrastructure (Austin Datacentre), VPN Technology (Austin IPsec's), Pelion (Pelion US Platform), and Mobile Operators (Telus).