Pelion Portal Customer Help Pages Unavailable
Incident Report for Pelion Connectivity Status
Resolved
This incident has been resolved.
Posted May 14, 2021 - 08:55 BST
Investigating
We are investigating issues with an error message on the Pelion portal customer help pages at https://help.iot-x.com/ and will provide an update shortly.
Posted May 14, 2021 - 04:05 BST
This incident affected: Pelion (Help.iot-x.com).