Pelion // JT/Pelion Global Roaming // Degraded Performance

Incident Report for Pelion Connectivity Status

Resolved

This incident has been resolved.
Posted Mar 31, 2025 - 10:51 BST

Monitoring

Status: Investigating & Monitoring Incident

Service Impacted:
JT/Pelion Global Roaming

Priority:
Medium

Pelion Environment Area(s) Affected:
UK & EU

Summary:
Pelion Support teams have been notified by the supplier JT/Pelion Global Roaming that they have had significant degradation in their IP cross connects overnight between 01:45BST to approx. 06:30BST, where they saw a significant decrease in traffic (approx 33%)
This may have had an impact on connectivity for these subscribers.


Update:
The supplier has advised that they believe the incident is resolved and they are seeing traffic returning to pre-incident levels.
Pelion are currently monitoring the issue but we do not believe this had a significant impact on Pelion subscribers at this time.



We will provide an update shortly and we apologise for any inconvenience.
Posted Mar 31, 2025 - 08:59 BST
This incident affected: Mobile Operators (Pelion Global Roaming).