Pelion // Three Ireland - Degraded Performance

Incident Report for Pelion Connectivity Status

Resolved

Pelion engineering teams are now seeing an improvement with Three Ireland performance
Posted Dec 05, 2025 - 16:52 GMT

Monitoring

Status:
Incident Update

Pelion engineering teams have identified and mitigated the issue and are currently monitoring. We believe there may be degradation roaming to EE through Three Ireland and are working with the supplier.
Posted Dec 05, 2025 - 12:48 GMT

Identified

Status:
Incident Update

Pelion Support & engineering teams are continuing to work through the reported issues.
Pelion engineering teams are working on mitigation attempts.

We will provide another update soon and we apologise for any inconvenience.
Posted Dec 05, 2025 - 11:27 GMT

Investigating

Status: Investigating Incident

Service Impacted:
Three Ireland

Priority:
High

Pelion Environment Area(s) Affected:
UK & EU

Summary:
Pelion Support teams are currently investigating issues with Three Ireland which may have an impact on your service.

Update:
Pelion engineers are investigating the reported issues.

We will provide an update shortly and we apologise for any inconvenience.
Posted Dec 05, 2025 - 10:00 GMT
This incident affected: Mobile Operators (Three IRE).