Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 12, 2025 - 23:00 GMT
Update
Please note that this maintenance was previously posted as Tele2 in error. It is O2 in the UK who are carrying out maintenance between 23:00 - 05:00 UTC.
Posted Mar 12, 2025 - 21:09 GMT
Scheduled
O2 will be carrying out essential maintenance between 12/03/2025 23:00 and 13/03/2025 05:00 UTC.
During this time O2 will be performing maintenance on the Pelion APN. Subscribers will disconnect and reconnect within the maintenance window.
Start Date and time: 12/03/2025 23:00 UTC
End Date and time: 13/03/2025 05:00 UTC
Services affected: O2 Subscribers will disconnect and reconnect within the maintenance window.
Customer action required: No customer action is required.
Posted Mar 07, 2025 - 17:41 GMT
This scheduled maintenance affected: Mobile Operators (O2).