Pelion // Telus // Partial Outage

Incident Report for Pelion Connectivity Status

Resolved

Status:
Resolved

We would like to inform you that the following incident with some Telus subscribers has now been resolved. Telus implemented a fix at approx. 12:50 Eastern Time and we have been monitoring traffic flows since this time.

We apologise for any inconvenience.
Posted Apr 15, 2025 - 18:57 BST

Investigating

Status: Investigating Incident

Service Impacted:
Telus

Priority:
High

Pelion Environment Area(s) Affected:
US

Summary:
Pelion Support teams are currently investigating issues with Telus which may have an impact on your service.
We have identified that some Telus susbcribers may be having some issues passing 2 way data traffic.
Some Telus SIMs are able to authenticate and some customer devices are able to pass traffic, so the issue appears to be inconsistently intermittent.

Update:
Pelion support teams are are currently investigating and are invoking Telus support and engineering teams.


We will provide an update shortly and we apologise for any inconvenience.
Posted Apr 15, 2025 - 16:41 BST
This incident affected: Mobile Operators (Telus).