We are continuing to monitor for any further issues.
Posted Apr 14, 2026 - 13:23 BST
Monitoring
Priority: Medium - Incident lowered to P3
Pelion Environment Area(s) Affected: UK & EU
Summary: Pelion engineering teams have moved our platform to our secondary instance, which is running successfully however we still expect delays to loading and data population. Provisioning is currently experiencing a partial outage.
We are currently monitoring performance data repopulation.
Posted Apr 14, 2026 - 11:40 BST
Update
We are continuing to work on a fix for this issue.
Posted Apr 14, 2026 - 11:20 BST
Identified
Priority: High
Pelion Environment Area(s) Affected: UK & EU
Summary: Pelion engineering teams have moved our platform to our secondary instance, which is running successfully however we still expect delays to loading and data population. APIs are still unavailable in some cases. Statistics graphs are not populated in some cases.
Next update available at midday.
Posted Apr 14, 2026 - 10:52 BST
Update
We are continuing to investigate this issue.
Posted Apr 14, 2026 - 10:03 BST
Investigating
Status: Identified Incident
Service Impacted: Pelion Platform EU APIs
Priority: High P2
Pelion Environment Area(s) Affected: UK & EU
Summary:
Pelion Support teams identified an issue with the Pelion Platform EU, customers may see errors upon login although are likely to loading errors across services.
The Pelion portal is currently at a reduced service due to an internal database error.