Pelion // Vodafone UK

Incident Report for Pelion Connectivity Status

Resolved

No further impact is observed.
SIM subscriber traffic is being served from Pelion's Manchester DC.
Posted Jun 08, 2025 - 20:14 BST

Monitoring

Status: Investigating & Monitoring Incident

Service Impacted:
Vodafone UK

Priority:
Medium

Pelion Environment Area(s) Affected:
UK

Summary:
Pelion Support teams have monitored that Pelion's primary link to Vodafone UK in our London datacentre has dropped.
Traffic has moved cleanly to our Manchester site, however there was a large increase in radius messages during this time. This may mean that SIM suscribers momentarily disconnected and reconnected.
Subscriber traffic is now being served normally from our Manchester DC.
Pelion is raising to Vodafone and we will continue to monitor for any impact.

We apologise if you monitored any impact.
Posted Jun 08, 2025 - 18:52 BST
This incident affected: Mobile Operators (Vodafone).