Pelion // Vodafone UK - Authentication issues

Incident Report for Pelion Connectivity Status

Resolved

Status:
Resolved

We would like to inform you that following a period of monitoring this incident has now been resolved.

Customer action required:
Customers may have to reboot/power cycle devices in the first instance if devices do not automatically reconnect.

We apologise for any inconvenience.
Posted Nov 26, 2025 - 11:32 GMT

Monitoring

Status:
Monitoring

We have identified and implemented a resolution; we are monitoring the resolution to ensure no further impact for this incident is experienced.

Customer action required:
Customers may have to reboot/power cycle devices in the first instance.

We apologise for any inconvenience.
Posted Nov 26, 2025 - 09:51 GMT

Investigating

Status: Investigating Incident

Service Impacted:
Vodafone UK

Priority:
High

Pelion Environment Area(s) Affected:
UK

Summary:

Pelion Support teams are currently investigating issues with Vodafone UK which may have an impact on your service.
We have identified from monitoring that customers using the Vodafone UK operator may be experiencing issues with authenticating on the network and devices may be unable to connect.

Update:
Pelion engineers are working on investigating this issue.


We will provide an update shortly and we apologise for any inconvenience.
Posted Nov 26, 2025 - 09:36 GMT
This incident affected: Mobile Operators (Vodafone).