Pelion // JT/Pelion Global Roaming // Partial Outage

Incident Report for Pelion Connectivity Status

Resolved

This incident has been resolved.
Posted Jul 28, 2025 - 22:17 BST

Monitoring

A fix has been implemented by JT's engineering teams in coordination with their carrier partners. Clear improvements in signaling success rates have been observed. Pelion have validated this against our own monitoring systems.

A period of monitoring is in place to ensure stability.
Posted Jul 28, 2025 - 20:29 BST

Update

The partner suppliers engineering work is ongoing, with further steps taken to ease network congestion.

Early signs of improvement are being observed.

Devices may continue to experience intermittent connectivity issues globally, with potentially greater disruption in the UK due to current network routing changes.

We will provide a further update as soon as possible and we apologise for any inconvenience.
Posted Jul 28, 2025 - 18:55 BST

Update

The suppliers engineering efforts are continuing with their carrier partner to reduce network congestion and restore normal service performance.

Devices may continue to experience degraded behaviour, including issues with both new session attempts and existing connections.

We will provide an update shortly and we apologise for any inconvenience.
Posted Jul 28, 2025 - 16:58 BST

Update

JT are continuing to work on a fix for this issue.
Posted Jul 28, 2025 - 16:13 BST

Identified

The JT/Pelion Global roaming supplier are continuing to investigate this issue.

Their engineering teams remain engaged with the carrier partners, and work is ongoing to restore normal performance.

We will provide an update shortly and we apologise for any inconvenience.
Posted Jul 28, 2025 - 15:46 BST

Investigating

Status: Investigating Incident

Service Impacted:
JT/Pelion Global Roaming

Priority:
High

Pelion Environment Area(s) Affected:
UK & EU

Summary:

Pelion Support teams have been notified by the Pelion global roaming supplier that they are currently investigating an issue affecting connectivity and data transmission.
One of their carrier partners is experiencing increased traffic on part of their network infrastructure (signalling links), which is contributing to degraded performance.

Update:
Pelion have investigated and we see some impact at this time.

The supplier has stated their engineering teams are working closely with the carrier to resolve the issue as quickly as possible.


We will provide an update shortly and we apologise for any inconvenience.
Posted Jul 28, 2025 - 13:51 BST
This incident affected: Mobile Operators (Pelion Global Roaming).