Pelion // Pelion Connectivity Management Portal // Service Outage

Incident Report for Pelion Connectivity Status

Resolved

Status:
Resolved

We would like to inform you that the following incident with Pelion Connectivity Management has now been resolved.

Customer action required:
No customer action required.

We apologise for any inconvenience.
Posted Mar 25, 2025 - 12:04 GMT

Monitoring

Status:
Resolved Under Monitoring

Pelion support teams identified and issue routing requests to the portal, this issue has been resolved. We are monitoring the resolution to ensure no further impact for this incident is experienced.

Customer action required:
No action required, existing sessions may require a page refresh.

We apologise for any inconvenience.
Posted Mar 25, 2025 - 11:23 GMT

Investigating

Status: Investigating Incident

Service Impacted:
Pelion Connectivity Management Portal

Priority:
High

Pelion Environment Area(s) Affected:
UK / EU

Summary:

Pelion Support teams are currently investigating issues with the Pelion Connectivity Management Portal which are impacting users ability to access this service.

We will provide an update shortly and we apologise for any inconvenience.
Posted Mar 25, 2025 - 11:08 GMT
This incident affected: Pelion (Pelion Platform).