Pelion // Vodafone UK Roaming

Incident Report for Pelion Connectivity Status

Resolved

Status:
Resolved

We would like to inform you that this incident has been resolved.

We apologise for any inconvenience.
Posted Mar 07, 2025 - 16:56 GMT

Monitoring

Status:
Our suppliers have advised that the Vodafone network seems to be recovering.
Network tests are passing on the MNOs and Pelion are monitoring that online device numbers are climbing back to pre-incident levels.

Please power cycle/reboot any devices where possible.

Pelion will keep this under monitoring until we have further confirmation from our MNO suppliers.

We apologise for any inconvenience.
Posted Mar 07, 2025 - 14:28 GMT

Investigating

Status: Investigating Incident

Service Impacted:
Vodafone UK Roaming

Priority:
High

Pelion Environment Area(s) Affected:
UK

Summary:

Pelion Support teams have been notifed by our suppliers that there is currently 2G and 4G/LTE data service degradation in Vodafone United Kingdom.
Subscribers are unable to establish 2G and 4G connections while roaming in this network.
Ongoing data sessions, voice, and SMS services are unaffected.

Customers are advised to steer devices to a different UK roaming network.

Pelion are attempting to mitigate the problem where possible.




We will provide an update shortly and we apologise for any inconvenience.
Posted Mar 07, 2025 - 14:13 GMT
This incident affected: Mobile Operators (Pelion Global Roaming, Tele2, Three IRE, Vodafone Global, Vodafone NB-IoT (LPWAN)).