Pelion support teams have implemented a fix which has seen an improvement in device recovery since approx. 20:00 GMT
We will continue to monitor and our engagements with Tele2 and their partners are ongoing.
Posted Apr 02, 2025 - 21:14 BST
Update
Pelion support teams are continuing to investigate this issue which is impacting some Tele2 subscribers.
We are seeing some levels of recovery, however, we have not reached pre-impact levels of online subscribers yet.
We will provide a further update shortly.
Posted Apr 02, 2025 - 19:47 BST
Identified
Status: Investigating Incident
Service Impacted: Tele2 Subscribers
Priority: High
Summary:
During a planned maintenance event tonight, we experienced an unexpected impact to service, which appears to be primarily impacting Tele2 subscribers, although Pelion support teams are still investigating the full impact. The impact was experienced from approx. 18:00 GMT.
We will provide an update shortly and we apologise for any inconvenience.