Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 13, 2026 - 19:00 GMT
Scheduled
We will be carrying out essential maintenance on 13/01/2026 between 19:00 and 23:00 UTC.
During this time we will be carrying out essential upgrades in our Manchester data centre, this involves the upgrade works of adding an additional internet redundancy link and Core Router upgrades directly related to our Three Ireland network operator.
Location: Manchester, UK.
Start Date and time: 13/01/2026 19:00 UTC
End Date and time: 13/01/2026 23:00 UTC
Services affected: Subscriber operator traffic routing via Manchester may experience a brief reconnection event during the upgrade works.
Customer action required: No customer action is required.
Posted Jan 09, 2026 - 17:37 GMT
This scheduled maintenance affected: Infrastructure (Manchester Datacentre) and Mobile Operators (Three IRE).