We would like to inform you that this incident has been resolved. Customers who are experiencing any impact should contact Pelion Support via the normal channels.
We apologise for any inconvenience caused.
Posted Oct 10, 2025 - 14:46 BST
Update
Status: Monitoring
We also identified an issue on the Three Ireland operator which was causing some devices to not be able to reach the the internet, we have now resolved this issue and customers who have raised a support ticket will be contacted by our Support teams to confirm restoration.
Pelion Support engineers are continuing monitoring to ensure no further impact is observed. Customers who are experiencing any impact should contact Pelion Support via the normal channels.
We apologise for any inconvenience.
Posted Oct 10, 2025 - 11:28 BST
Monitoring
Status: Investigating Incident
Service Impacted: London and Manchester Datacentre
Priority: High
Pelion Environment Area(s) Affected: UK & EU
Summary:
Pelion Support teams are currently monitoring recovered events within the London and Manchester datacentres which may have had a short impact on your service.
We have identified from monitoring that London VPN's moved from their primary to secondary hosts, most VPN's recovered automatically and Pelion Support engineers manually recovered other VPN's. Customers may have seen IPsec VPN's disconnect and then reconnect.
Pelion Support engineers then monitored an outbound internet outage from our internet provider in our Manchester Datacentre. Traffic was moved gracefully to our redundant provider outbound internet was re-established as expected. All services and IPsec VPN's haver recovered as expected.
Update: Pelion Support engineers are monitoring to ensure no further impact is observed. Customers who are experiencing any impact should contact Pelion Support via the normal channels.
We will provide an update shortly and we apologise for any inconvenience.
Posted Oct 10, 2025 - 09:57 BST
This incident affected: Infrastructure (London Datacentre, Manchester Datacentre), Mobile Operators (EE, Tele2, Three IRE, Three UK), and VPN Technology (London IPSecs, Manchester IPSecs).