Network issue on Vodafone UK
Incident Report for Pelion Connectivity Status
Resolved
This incident has been resolved.
Posted Nov 27, 2020 - 08:46 GMT
Investigating
We are currently investigating a network fault on Vodafone UK and this may be causing connectivity issues.
We are investigating this with Vodafone UK at the moment.
We will provide a further update as soon as possible.
Posted Nov 26, 2020 - 18:14 GMT
This incident affected: Mobile Operators (Vodafone).