Tele 2 - Slow Download Speeds
Incident Report for Pelion Connectivity Status
Resolved
We can confirm customers are seeing download speeds return to normal across their Tele2 SIMs.
Posted Feb 15, 2021 - 16:02 GMT
Monitoring
Tele2 have made a configuration change which should see speed performance return to normal operating levels. We will continue to monitor connections and throughput to ensure the issue is resolved.
Posted Feb 12, 2021 - 10:28 GMT
Identified
Tele2 has identified the cause of the performance issues and are currently making changes to their configuration to return download speeds to expected levels. We remain in close contact with Tele2 during these work and we will provide further updates as and when we receive more information.
Posted Feb 11, 2021 - 18:03 GMT
Investigating
We are investigating issues with slow download speeds with some Tele 2 subscribers.
We are investigating this issue with Tele 2 and will provide an update shortly.
Posted Feb 11, 2021 - 14:32 GMT
This incident affected: Mobile Operators (Tele2).