Three UK 4G Data degradation
Incident Report for Pelion Connectivity Status
Resolved
Three have resolved this incident
Posted Jul 31, 2020 - 21:40 BST
Investigating
Three UK have advised that they are investigating and identified an issue affecting degradation on their 4G services.

This is affecting a small percentage of the subscriber base and subscribers may be experiencing degraded data performance when on 4G.

There is no impact to 3G services.

We will continue to provide updates as these become available.
Posted Jul 31, 2020 - 14:27 BST
This incident affected: Mobile Operators (Three UK).