JT/Pelion Global Roaming, Tele2, Vodafone Global - Intermittent Connectivity Issues
Incident Report for Pelion Connectivity Status
Resolved
This incident has been resolved. We request you to please power cycle your device(s) once if you are still facing the issue.
Posted Nov 23, 2021 - 12:12 GMT
Update
We are continuing to monitor for any further issues.
Posted Nov 22, 2021 - 18:22 GMT
Monitoring
A fix has been implemented and we are monitoring the results. If you believe your device may be impacted, please fully restart/power cycle your device in the first instance.
Posted Nov 22, 2021 - 12:37 GMT
Investigating
We are investigating issues with Intermittent Connectivity on JT/Pelion Global Roaming, Tele2, and Vodafone Global SIM's.
Pelion engineers are investigating and we will provide an update shortly.
Posted Nov 22, 2021 - 12:18 GMT
This incident affected: Mobile Operators (Pelion Global Roaming, Tele2, Vodafone Global) and Infrastructure (Manchester Datacentre).