Pelion Email Support Tracking
Incident Report for Pelion Connectivity Status
Resolved
Pelion Support teams have resolved the issue where support emails to pcm-support@pelion.com were not being received.

All emails are now being received and any outstanding replies are being sent to customers in the order they were received.
This may take some time to work through, however if customers have not received replies to emails within the next 24 hours, please call us on the below contact phone numbers:

o United Kingdom
▪ Local: + 44 (0)844 800 8520
▪ Local: +44 (0)808 196 5001

▪ International: +44 141 483 7545

o United States of America
▪ Local: +1 855 755 0065
▪ International: +1 650 300 0065

We apologise for any inconveniece caused and thank you for your patience.
Posted Jun 29, 2022 - 16:46 BST
Identified
We have identified the issue where support emails to pcm-support@pelion.com were not being received.

Until we resolve this matter, customers are requested to contact the Pelion Support team via the

Support Portal: https://support.pelion.com/

or

Call us on the below contact phone numbers:

o United Kingdom
▪ Local: + 44 (0)844 800 8520
▪ Local: +44 (0)808 196 5001

▪ International: +44 141 483 7545

o United States of America
▪ Local: +1 855 755 0065
▪ International: +1 650 300 0065

Update:
emails to pcm-support@pelion.com can now be received and a ticket will be logged for any incoming emails.
Unfortunately, replies cannot be sent to customers at present. Customers who do require immediate assistance with their case are requested to provide a contact phone number in their email and a member of our team will be in touch.

Otherwise, replies to emails will be delayed.

Our Support teams have engaged and are working with the relevant vendor partners to resolve the issue as quickly as possible.

We apologise for any inconvenience caused.
Posted Jun 29, 2022 - 14:33 BST
Update
We are currently looking into an issue where support emails to pcm-support@pelion.com are not being received.

Until we resolve this matter, customers are advised to contact the Pelion Support team via the

Support Portal: https://support.pelion.com/

or

Call us on the below contact phone numbers:

o United Kingdom
▪ Local: + 44 (0)844 800 8520
▪ Local: +44 (0)808 196 5001

▪ International: +44 141 483 7545

o United States of America
▪ Local: +1 855 755 0065
▪ International: +1 650 300 0065

Customers are advised not send emails to pcm-support@pelion.com as we cannot guarantee that emails will be received and actioned.
Posted Jun 29, 2022 - 11:28 BST
Investigating
We are currently looking into an issue where support emails to pcm-support@pelion.com are not being received. Till we resolve this matter, customers are advised to contact the Pelion Support team via the

Support Portal: support.pelion.com
or
Call us on the below contact phone numbers:

o United Kingdom
▪ Local: + 44 (0)844 800 8520
▪ Local: +44 (0)808 196 5001

▪ International: +44 141 483 7545

o United States of America
▪ Local: +1 855 755 0065
▪ International: +1 650 300 0065

We will send an update notification when this is resolved.
Posted Jun 28, 2022 - 17:21 BST
This incident affected: Services (Support Ticketing).