Vodafone UK Voice Incident
Incident Report for Pelion Connectivity Status
Resolved
Vodafone UK have advised that this incident has been resolved.
Posted Jun 19, 2020 - 14:59 BST
Identified
Vodafone UK have advised and are investigating possible issues with 2G and 3G voice and will provide an update shortly.
Posted Jun 19, 2020 - 14:24 BST
This incident affected: Mobile Operators (Vodafone).